• 0

    posted a message on AutoBar by Toadkiller (official thread)
    Quote from tenagra »

    how do you set a keybind for a custom button? Keybinding to the premade named buttons is easy enough, but i can't seem to figure out how to do it for custom buttons.


    /script SetOverrideBindingClick ( AutoBarButtonCustomCustomButton37Frame, false, "Numpadplus", "AutoBarButtonCustomCustomButton37Frame" )


    This will bind the numpad + key to CustomButton37 for the current session (it won't be saved on logout). Replace the key name and the number of the custom button for your setup.
    Posted in: General AddOns
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    Hi! Autobar works fine so far, but I want to reduce the number of keyboard shortcuts (or buttons). Maybe this is an FAQ, but I couldn't find the answer here.

    Can you please explain how categories (named buttons) can be merged? Alternatively, I want to create custom categories in which some default buttons can be copied. But I do not want to use the empty custom button and add each item manually, because there are sooo many items and they are already in the default buttons.

    E.g.: Where do I have to click to get one Water button with Water, Water Buff, Water Combo and add Conjured Manna Biscuit to it as well?
    Posted in: General AddOns
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Thanks for your answer.
    Yes, it is reproducible. I solved the problem by deleting the !!!StandaloneLibraries directory and installed it as a new addon again. So, the directory seems to be in an invalid state, although I have enabled the "delete before updating" option.

    I have attached the directory, so I hope you can reproduce the error.
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Unfortunately, I have to report (my first) infinite loop bug on splitting the !!!StandaloneLibraries with jWowUpdater 1.43 (just updated from 1.36). After 10 minutes or so there was even an error in the same splitting it has done many times... Strange.
    Logfile is attached as text. All config options are enabled (no ext, cleanup, split, etc.).
    Posted in: Updaters
  • 0

    posted a message on AuldLangSyne 2.0
    I can confirm Farook's bug report in the FuBar tooltip. Friends without a note will display a duplicate of the note in the line above.
    Posted in: General AddOns
  • 0

    posted a message on AuldLangSyne 2.0
    I just started with Auld (42216), but the import from CT_Core with "/auld note ctimport" fails with this error:

    Interface/AddOns/AuldLangSyne_Note\Note.lua:332: attempt to index field 'friend' (a nil value)

    Player notes in CT_Core are still working.
    Posted in: General AddOns
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from rolfba »

    1. You are not supposed to set the addons folder, just the world of warcraft folder. So if you set the path to "path to wow folder\interface\addons", you need to reset it to just "path to wow folder".


    Ah, yes! That helped alot, thank you very much. Now it works as supposed.

    One small additional note to 4: For some unknown reason the scrolling did not stop on finishing the update. But I'm not able to reproduce this error or the NullPointerException. Currently, it works fine.

    /happy
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Hello everyone!

    I'm new here and just started with the jWowUpdater 1.26. Unfortunately, I can't get it to work. There are several issues listed below and I hope there is a simple solution:

    1. The program does not change any files in the designated addon folder. Not on install, not on delete, not with the no-externals option on or off. The files won't be changed.
    2. jWowUpdater does not detect the installed addons in that folder by itself. I have to "install" the already existing addons. Only after this step, they are detected with their current build numbers for the update process. However, no files on the disk will be changed on an update either.
    3. Both frames for installing and deleting, can only be closed with the cancel button, but not with the "X" in the upper right corner.
    4. The large text frame in the main window sometimes (when updating?) has an unstoppable, automatic scrolling to the bottom, which makes it impossible to read any text which scrolled out of the view.
    5. Once I got a NullPointerException, see below:
    Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at javax.swing.plaf.basic.BasicProgressBarUI.updateSizes(Unknown Source)
    at javax.swing.plaf.basic.BasicProgressBarUI.getBox(Unknown Source)
    at javax.swing.plaf.metal.MetalProgressBarUI.paintIndeterminate(Unknown Source)
    at javax.swing.plaf.basic.BasicProgressBarUI.paint(Unknown Source)
    at javax.swing.plaf.ComponentUI.update(Unknown Source)
    at javax.swing.JComponent.paintComponent(Unknown Source)
    at javax.swing.JComponent.paint(Unknown Source)
    at javax.swing.JComponent.paintWithOffscreenBuffer(Unknown Source)
    at javax.swing.JComponent.paintDoubleBuffered(Unknown Source)
    at javax.swing.JComponent._paintImmediately(Unknown Source)
    at javax.swing.JComponent.paintImmediately(Unknown Source)
    at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
    at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)

    I use a Windows XP machine with Java 1.5.0_03-b07. Except the error above there are no error messages from the program. The file permissions of the addons directory can't be wrong as I tested this on a FAT32 drive.

    Any suggestions?
    Posted in: Updaters
  • To post a comment, please or register a new account.