• 0

    posted a message on Error while pushing to a git repository
    It's working now (-: Thanks!
    Posted in: General Chat
  • 0

    posted a message on Fortress (unofficial thread)
    The disabled brokers bug was fixed some times ago, but the fix seems to be lost. It'll work in the next alpha version, that will be released as soon as the repository works again.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Error while pushing to a git repository
    Hello,

    since yesterday I'm getting an error message when I try to push changes to the Fortress git repository. Here's the error message:


    Traceback (most recent call last):
    File "./serve", line 38, in <module>
    sys.exit(run(repo_type, user))
    File "./serve", line 32, in run
    return serve(user, *args)
    File "/repos/repository_serve/git.py", line 43, in serve
    access_level = get_access_level('git', user, path)
    File "/repos/repository_serve/db.py", line 187, in get_access_level
    result = _get_access_level(repo_type, user, game, project, repo)
    File "/repos/repository_serve/db.py", line 256, in _get_access_level
    if repository.is_open:
    AttributeError: 'Repository' object has no attribute 'is_open'
    fatal: The remote end hung up unexpectedly
    I checked the packager status page the first time this error appeared and it showed 'Status: Failed' and something about an exception while packaging an other addon. Maybe the Fortress repo was opened just before this exception and not closed properly.

    Thanks in advance,
    Borlox
    Posted in: General Chat
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from gagou
    I modified Fortress on my local copy to test texcoord and it's working, in red what I've added.


    It seems LegoBlock isnt messing with the icon. Thanks for the code:)
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from sayntavarice
    An option to show/hide suffix would be a good addition.


    I'll add this option.

    Quote from gagou
    it seems that some ldb addon now use a texcoord argument to modify the texture used for the icon.
    picoButtons by tekkub is an example.

    Can you please use this texcoord argument to properly display the icon as intended by the author of the plugin?


    .texcoord is not in the official spec, but I'll look for some information about this. I'm not yet sure that this is added, as the LegoBlock lib (used for the blocks) does not support TexCoord, so some hacks may be needed.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Addon using AceGUIWidget-Dropdown?
    There are two ways of using the dropdown widget(s): Either as a list of checkboxes (as AceConfigGUI-3.0 is doing) or as a real dropdown menu with more button types.

    For 1:
    local dropdown = AceGUI:Create("Dropdown")
    
    -- set the dropdown list (table of id=text_to_display)
    dropdown:SetList({
      ["choice1"] = "Text for Choice #1",
      ["choice2"] = "Text for Choice #2",
      -- and so on
    })
    dropdown:SetValue("choice1") -- choice1 is checked initialy
    
    dropdown:SetCallback("OnValueChanged", function(choice)
      -- choice is the list index of the selected item
    end )
    
    -- add the dropdown to your frame
    You can have a multiselect dropdown by using dropdown:SetMultiselect(true). The callback for multiselects is also "OnValueChanged" with the parameters (choice, isSelected).

    For 2:
    In this case you'll have to use the Dropdown-Pullout directly, and add some items yourself.

    To create a menu with this structure you can use the following code:
    - "Some header text"
    - Button1
    - A Submenu
    -- A checkbutton
    -- (separator)
    -- Another button

    local dropdown = AceGUI:Create("Dropdown-Pullout")
    
    local header = AceGUI:Create("Dropdown-Item-Header")
    header:SetText("Some header text")
    dropdown:AddItem(header)
    
    local btn1 = AceGUI:Create("Dropdown-Item-Execute")
    btn1:SetText("Button1")
    btn1:SetCallback("OnClick", function() print("Button1 clicked") end)
    dropdown:AddItem(btn1)
    
    -- create submenu
    local submenu = AceGUI:Create("Dropdown-Pullout")
    
    local subCheck = AceGUI:Create("Dropdown-Item-Toggle")
    subCheck:SetText("A checkbutton")
    subCheck:SetCallback("OnValueChanged", function(checked) print("Checkbox is", checked and "checked" or "not checked") end)
    subCheck:SetValue(false) -- not checked
    submenu:AddItem(subCheck)
    
    local sep = AceGUI:Create("Dropdown-Item-Separator")
    submenu:AddItem(sep)
    
    local subBtn = AceGUI:Create("Dropdown-Item-Execute")
    subBtn:SetText("Another button")
    submenu:AddItem(subBtn)
    
    local menuItem = AceGUI:Create("Dropdown-Item-Menu")
    menuItem:SetText("A Submenu")
    menuItem:SetMenu(submenu)
    dropdown:AddItem(menuItem)
    
    -- later in your code
    -- show the pullout at the center of the screen
    dropdown:Open("CENTER", UIParent, "CENTER", 0, 0)
    The dropdown pullout was designed to be a base for a possible AceConfigDropdown-3.0 implementation, so it has no fancy opening widget like the Dropdown widget.
    See AceGUIWidget-DropDownItems.lua for information about how to add your own item types.

    I hope this helps you.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Time to scrap Display advertising
    Some sort of tagging for LDB displays would be useful for users, especially for new ones.
    But I agree, as LDB plugins are display-independent, there should be no advertising.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from Lichbane
    Enabling, Disabling and Locking the bars seems to behave strangely. If I lock the bar, all the disabled broker addons appear ... though they are still marked as disabled.


    Thanks for the report, this should be fixed in the new alpha.

    Quote from Sayclub
    koKR update


    Thank you!
    Posted in: Data Broker AddOns
  • 0

    posted a message on Broker: Transit (Official)
    Looks really interesting!

    But... I'd classify it as type = "launcher" as it doesn't show any information...
    /me cowers in fear of a punch
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from saltorio
    OK. I'm currently testing F2B r73, and so far so good. I just hearthed, and despite the hearthstone cooldown ticking away in the TransporterFu tooltip, I can view other addon's tooltips without them disappearing (or closing and having the TransporterFu tooltip open instead).

    So far, so good.



    So, it's actually working as it should? :eek:
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from HunterZ
    So I'm wondering if the issue with phantom tooltips appearing is because F2B's OnEmbedEnable() method is calling FuBarPlugin:OpenTooltip() as part of its addon.UpdateTooltip handling, which now in turn calls tablet:Open().


    FuBarPlugin:OpenTooltip should not get called, because currentTip[addon] should be nil (in addon.UpdateTooltip).

    I'd do some more debugging, but I killed my WoW installation (some corrupted files) and have to reinstall (without my CDs...). That'll take a while :(
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from HunterZ
    Someone in the F2B thread says they're mousing over one FuBar plugin and seeing the tooltip for a different FuBar plugin. I wonder if that might be a distinct 3rd issue raising its head though.


    :confused: Is there any possibility to just remove Tablet?

    Maybe it's enough to call tablet:Open and don't call tablet:Refresh in FuBar2Broker:OpenTooltip(), as tablet:Open seems to a refresh itself. I have no possibility to test this, but maybe this causes the false tooltips when switching fast from one tooltip to another one.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from ara2
    You use "secureTemplates" while SBC use "secureTemplate", what's the best ? I feel both stand correct depending of the point of view (names are annoying :p).


    Uh... I'll change it to secureTemplate, SBC was the first to implement it.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from dafire
    is there a reason the fortress tooltips are mouse enabled ? If you align the blocks vertically that's annoying that you can't move from block to block because the next block is covered by the tooltip and it will stay if you hover the mouse over it.

    maybe make it configurable ?


    I think there was a reason but I can't remember it. I see what I can do.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from ant1pathy
    I update as often as Curse lists them as updated ;).


    The mentioned version is beta, so you're right, the newest release doesn't have sorted options. In my opinion the beta versions are stable enough, so you could use the 1.1-beta4, downloadable here.


    I think I'll release 1.1 once the tooltip problems with tablet are fixed. The new F2B version should handle this, but it will need more testing.

    My plan for the next version is code cleanup (it got really messy...) and a cleaner config. At the moment there are no plans for new features, except maybe text alignment and some other minor stuff.
    Posted in: Data Broker AddOns
  • To post a comment, please or register a new account.