• 0

    posted a message on Fortress (unofficial thread)
    Quote from HunterZ
    I thought the original problem was that tooltips weren't showing for some people at all (or maybe they stopped showing after 1-3 times?)?

    I did not hear of this problem before the changes.


    What? How is Fortress reverting a Tablet hook?
    In Fortress' OnEnter code:
        if TABLET20_FIX and self:GetScript("OnEnter") ~= Block_OnEnter then
            self:SetScript("OnEnter", Block_OnEnter)
        end

    Also, keep in mind that Fortress isn't the only LDB display out there. I'm seeing the new issue (tablet tooltips appearing out of the blue) with ButtonBin, while others are seeing it with Fortress. If a fix is needed then it should probably go in F2B unless it's truly a flaw in the displays.
    I'm not sure, but maybe the problems happen because the Tablet Tooltip is shown twice when the hook is not reverted (for example with ButtonBin or an older Fortress version). Maybe it works when F2B deletes the hook, so tablet:Open is only called once. I would test this myself, but as I never had one of the problems theese tests would'nt be that significant.


    Stupid Tablet.
    *sigh*


    Edit:
    I just found something better than playing around with the hooks. Tablet's :Register takes 'dontHook', true as an argument.

    Maybe the following works:
    - keep any display as it is
    - keep the tablet:Open in F2B's :OpenTooltip
    - add 'dontHook', true to F2B's tablet:Register call
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    The original problem was, that Tablet tooltips appeared though Fortress did not send an OnEnter/OnTooltipShow or whatever. That's because Tablet is hooking the OnEnter script of the tooltip's 'parent' frame to open the tooltip itself (arround line 2534 in Tablet-2.0.lua). Now (=lates beta versions) Fortress is reverting this hook and the tooltip should be shown in F2B's :OpenTooltip().
    I really don't know how the changes can cause any of the mentioned problems.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    I never experienced this behaviour, so to be honest I've no idea why this happens. I think the best thing is reverting to an older revision until I (or someone else) finds the bug.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    The packager is running again and I uploaded 1.1-beta2 with the sorted option list and the secure stuff. The shared media thing has to wait till tomorrow, as I'm to lazy to add all those new local bits...
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Some more changes (still unreleased due to the packager problems...):

    - The plugin list in the options frame is now sorted (thanks to Xinhuan, he explains the whole stuff in the LDB thread)
    - Experimental support for LibSharedMedia for Font, Background and Border using yssaril's great widgets
    - Support for .secureTemplates and .OnCreate (though it's not in the official spec)
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    I just uploaded the first beta for version 1.1, it should be available in about 20 minutes.

    Features:
    - real profile support (ticket #4)
    - tooltips are hidden when a block is clicked (ticket #7)
    - the default profile's name is now 'Default' (ticket #8)
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    I'm back again.

    For the whitespace around the blocks, try to disable the "Show border" setting. THe blocks should fit together without any whitespace then.
    Posted in: Data Broker AddOns
  • 0

    posted a message on [fun] self-reproducing code
    It's drycoded 'cause I have no Lua interpreter at this computer, but I think this should work.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Fortress (unofficial thread)

    Strange.. I'm using Fubar2Broker together with Fortress and now the Tooltip wont show. It shows a two times when i mouseover but then nothing.


    Which version of Fortress do you use? The newer Alpha versions have a fix for Tablet-2.0 problem, but this fix requires a change in FuBar2Broker, that's not yet published. You could either use the stable version Fortress-1.05, disable the fix in the alpha version by editing Core.lua (somewhere at the top there's a line 'local TABLET20_FIX = true', change the true to false) or by editing FuBar2Broker (new FuBar2Broker.lua: http://pastey.net/99935).
    Posted in: Data Broker AddOns
  • 0

    posted a message on StatBlockCore v2: Make use of your broker plugins!
    Even if it's not "official", it's a really interesting idea. That would allow a whole bunch of new broker plugins.
    Posted in: Data Broker AddOns
  • 0

    posted a message on StatBlockCore v2: Make use of your broker plugins!
    Quote from funkydude

    -NEW support for creating secure blocks: Many thanks to Aranarth for the endless debate & discussion! This will allow more power to blocks, Aranarth's in particular :P


    What's the spec for this? Is it just obj.secureTemplates (as 4. CreateFrame param) and obj.OnCreate(obj, frame), or am I missing something?
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from glithramir
    You dont need to say sorry for anything. The addon is great and I appreciate that you made it possible for us to use it in the first place. Take your own time in fixing it.. =)

    :)

    I just finished version 1.05 with following changes:
    - The slash cmd error is fixed.
    - A 'disable tooltip' setting is added.
    - One issue with the 'hide tooltip in combat' setting is fixed.

    There's another problem with the 'hide tooltip in combat' setting and FuBar plugins using FuBar2Broker. Some of these plugins are using Tablet-2.0 which is overriting the Fortress OnEnter handler and showing the tooltip itself. I cannot change this behaviour from Fortress, but I'll create a patch for FuBar2Broker and submit it to it's author.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    I'm back at home for the weekend, but there's still a week without my computer ahead, so I cannot make any promises.

    I plan to fix the 'hide tooltip in combat' bug and maybe add a general 'disable tooltip' setting. Any other changes to block customization (like font changes, other textures and so on) will have to wait a bit more :(.
    I think I'll replace the LegoBlocks library with something self made to have more control over the blocks. That should simplify font/size/etc. settings but will need some time to code and debug.

    I'm sorry that the whole development is so slow at the moment, but well... I had no time to play wow or code addons in the last two weeks, so please be patient.

    -Borlox
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    I'll look into this as soon as possible, but as I'm away for about 2 weeks I cannot make any promises.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Fortress (unofficial thread)
    Quote from andreasg
    Hey Borlox, where is the current dev source? On Git on the new wowace?


    Aye, I moved the old svn repo to git at WoWAce. I played a bit with it, but I'm not sure everything works, and as I have no access to my computer till mondey I cannot really test it. Worst case would be reverting everything to SVN, but I think the git repo should work.
    Posted in: Data Broker AddOns
  • To post a comment, please or register a new account.