• 0

    posted a message on Skillet - Official Thread
    The buttons added to the skillet frame by the function in ThirdPartyHooks, even though it checks if the button is the same, can somehow still be added in and the old button not created.. EG AckisRecipeList's Scan Recipes button. If I open the skillet window, then close it, then open the same one again, the button is spaced farther to the left, as if the original button was added to the frame still.
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Just a quick update re: plans from the opposite faction..

    I just got around to checking some of the recipes that show as unlearned for me.. The first one is Barbaric Iron Breastplate.. It is a recipe obtained from a horde quest, and I am alliance. The only way I could get it would be to buy it from the neutral ah, making it one of those 'difficult to obtain' recipes..
    Posted in: General AddOns
  • 0

    posted a message on Damage Meeter
    Quote from Ammo »

    Synchronization implies that there is some kind of two-way communication. This is one way, fire and don't care etc.

    -Ammo


    So it's like talking to either a retard, or to Space Ghost, then?
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Quote from feldarak »

    ok im not sure what it was, tried looking for the savedvariables still no luck...finally just deleted the ARL folder and reinstalled with the updater and it works great :) even reloaded all my other mods and its still workin fine...thanks for the help

    One thing to try, if you are using WAU, is to go into the preferences and enable the option to Delete Before Updating.
    Posted in: General AddOns
  • 0

    posted a message on OneBag 2.0.6026 [Released 7/28/2006]
    When I change the frame's vertical alignment for OneBank (OneBag works fine) from top to bottom, I get the following error (due to using bag break). If I separate out the conditions into if's, then I don't get the error, but then the bags start overlapping one another in the bank frame. Turning off bag break or using the slash commands to set it back to top vertical alignment (while not doing what I want) gets rid of the error.

    Date: 2007-10-24 19:26:01
    ID: 39
    Error occured in: Global
    Count: 2
    Message: ..\AddOns\OneBag\OneCore.lua line 571:
     bad argument #1 to 'fmod' (number expected, got nil)
    Debug:
     [C]: ?
     [C]: fmod()
     OneBag\OneCore.lua:571: OrganizeFrame()
     OneBag\OneCore.lua:160: func()
     ...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:721:
       ...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:660
    AddOns:

    [-snip-]

    If you need my addon list, let me know
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Quote from Ackis »

    Fixed.

    I'll slowly work on it :P LOL Or maybe I just did it. I'm not sure.

    You're using skillet right? I don't have it anchored to the skillet frame just yet. Did you notice that there was a scan button showing up in the Skillet UI?

    As for the scroll bar, I'm trying to get that working, not really sure why it works one way but not the other lol

    There's an issue with multi-line outputs and too long outputs for the gui, not sure how to handle it at this moment though.


    No scan button in skillet, but then again, I'm not seeing it with the default tradeskill window either. Perhaps another addon is blocking it (enchantrix?).. I'll disable everything and retest in a bit and let you know..

    To fix the issue with the long text, just hard wrap everything in the locales with \n for now and worry about it later.
    Posted in: General AddOns
  • 0

    posted a message on Skillet - Official Thread
    Quote from nogudnik »

    Yup, these are both bugs and I'll get at 'em tonight. Good catch, thanks!


    It doesn't even have to be in OnInitialize, it can be outside of everything and just in the file, like you would do when declaring a local var to be used throughout the whole file.
    Posted in: General AddOns
  • 0

    posted a message on Automaton
    Quote from Teibidh »

    Could you perhaps look in to the capacity to add a list of white, green and other items to the sell.lua module? The ability to filter grays is great, and allows me to use this in place of Autoprofit/AutoprofitX for basic functionality, but Autoprofit also allowed the selling of non-gray items once they were specified. Essentially it checked every item against its 'exception' list. If a gray item was on the list it didn't get sold, if a non-gray item was on the list it would get sold. Not sure how well that logic would fit in to the code you've already written, but it would make the product complete for me. Great job, btw, just used it for the first time today and it already saved me clicking a bunch of duel declines and prevented me from wasting time realizing I was still in cat or bear form when clicking a quest object. Thanks!


    I didn't write any of this code.. I've just provided a couple of bugfixes. I'm not the maintainer (unfortunately he isn't available anymore as it seems he quit playing the game), but personally I don't think it would belong in the sell module. Perhaps someone wouldn't mind at some point stepping up and writing a separate module for it, but regrettably I can't do it due to a lack of time and obligations to other mods and RL.
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Quote from feldarak »

    tried disabling all but ARL and lib:ace2, still no go

    ive got listed in addons the CT group (barmod, bottombar, buffmod, core, expense history, mailmod, mapmod, partybuffs, RAbossmod, raidassist, timer, unitframes, and viewport), ARL, itemrack, fishing buddy, lib:ace2, lib:threat 1.0, omen, and quartz

    thought i read ace2 was the only dependancy? am i wrong and missing something?


    the only thing i can think of is that somehow it got put on standby in ace2.. Try deleting the ARL savedvariables, and if that dont work, try deleing the ace2 savedvariables if there are any.
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Also, the description of how to get smelt elementium is too long for the frame, and in the case that the list isn't longer (downward) than the frame size, the scroll bar should be disabled.

    P.S. The scroll up button still doesn't work, although the frame does work much better now (still opens up in a weird spot, but inbd)
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Please replace line 1438 of AckisRecipeList.lua with this:

    addTradeSkill( BTS["Sulfuron Hammer"], 300, L["Sulfuron Hammer Obt"], L["Raid"] )


    It will fix an lua error I get when scanning blacksmithing.. thx.

    I got another hater fix if ya dont mind too lol.. Remove the spaces before and after ().. Make the above line like:

    addTradeSkill(BTS["Sulfuron Hammer"], 300, L["Sulfuron Hammer Obt"], L["Raid"])


    It will reduce filesize
    Posted in: General AddOns
  • 0

    posted a message on Skillet - Official Thread
    Quote from lilsparky »

    nothing skillet related. the updater i'm using on my mac is the java one and it seems to like to install TONS of libraries at the root level of the addons folder. i'm thinking that maybe one of them has been updated and is causing an issue.

    it's weird cuz skillet actually loads okay (insofar as lsw plugs into it and finds the version number w/o difficulty). i'm thinking skillet doesn't properly initialize beyond that point, which probably gets into ace stuff.

    edit: hmm... odd. loading up with just skillet and lib:ace2 still no go.


    lol. okay, got it. i was playing with standby to see if i could recreate that other error from the thread. i guess i logged off with skillet disabled. since it was disabled, i couldn't tell it to re-enable. the "/skillet" command registration must happen inside the disabled code.

    had to edit the skillet saved variables and re-enable it.




    That may be a bug, but I'm not sure. I think it is supposed to register the slash commands whether it is in standby mode or not tho..

    At any rate, thanks nogudnik for fixing the issue.. One minor nit is that when I take it out of standby, the options window opens. If it's a side effect of re-enabling some code, no problem and I'll just ignore it.

    Edit: And now that I fixed a bug in ARL (locale bug) and reloaded ui, if I type /skillet standby, I get this in ChatFrame1:

    09:48:16 Skillet (standby): Disabled
    09:48:16 Skillet: State is now set to [Suspended]

    and the default tradeskill window doesn't open again, nor the skillet tradeskill window.....
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Quote from feldarak »

    just got...rev 53044 without externals from the aceupdater

    no msg other than the standard type 'help' for a list...


    Can you list all of your addons please? This has to be some sort of conflict. Also, try disabling all addons, except for ARL and Ace2 (the depends will be re-enabled by Ace2).
    Posted in: General AddOns
  • 0

    posted a message on Automaton
    You should read the first few lines of Automaton\modules\sell.lua

    hehe..

    To quote: "if there are any grey items you wish autosell to ignore, add them to the following table"
    Posted in: General AddOns
  • 0

    posted a message on Automaton
    Quote from Quokka »

    Just sign up for AV than talk to the AB Battlemaster sign up there, and go the WSG Battlemaster and sign up there. 3 queues max at this time!

    Hmm.. I always thought if you were in a queue and joined another you left the first one. Shows how little I do BG's heh..
    Posted in: General AddOns
  • To post a comment, please or register a new account.