• 0

    posted a message on Recount
    Quote from Elsia »

    Yep, BamMod causes the problem.

    Edit BamMod.toc and change the following line to:

    ## OptionalDeps: Ace2 ParserLib


    I'm currently running Recount and BamMod without errors after this change.



    Amazed and much appreciated that you even tracked down how to correct the issue in BamMod. I did have to do an extra step on my end. I also had to download the latest ParserLib from the SVN and replace the one in the Lib directory of BamMod (the ParserLib.lua). Everything is working great now :D, thanks again.
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Quote from vict »

    I've been getting the same error as eve and my recount has also been "broken" -- it hasnt been recording data.

    personally, i've narrowed it down to bammod (QQ i liked that mod!); it's a somewhat outdated mod but it used to work with an older version of recount. with the newest version however, i get the same error that eve has been getting and recount hasn't been functioning correctly.

    hopefully this will help..


    When I get back to my computer I'll double check this to verify it on my end, but I also use the BamMod. Big QQ from me :/
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Alright, I went ahead and downloaded the latest from the SVN. I deleted before installing, loaded up WoW, cleared BugSack, reset the data from Recount, and actually logged completely out of WoW before loading up again.

    Only one error popped up in BugSack, and it was the same one I have been getting from Recount.

    [2008/01/30 20:30:06-592-x1]: Recount-$Revision: 59730 $\Recount.lua:1049: attempt to call method 'RegisterInfoType' (a nil value)
    AceAddon-2.0-57245 (Ace2):926: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:919>
    <in C code>: ?
    AceEvent-2.0-56171 (Ace2):263: in function `TriggerEvent'
    AceEvent-2.0-56171 (Ace2):914: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:907>


    The next thing I tried doing was disabling all addons except for BugSack and Recount. I cleared BugSack, reloadui, and received another error. This time is was different:

    [2008/01/30 20:33:37-594-x1]: AceOO-2.0-38641 (BugSack):734: AceComm-2.0: AceComm-2.0 requires AceEvent-2.0
    AceComm-2.0-58185 (Recount):2301: in main chunk


    I disabled BugSack and loaded only Recount and had no apparent errors and it seemed to be recording properly. I then tried loading all my Addons except BugSack and I got the original error again.

    I had to prepare for a raid so didn't go one by one with each Addon, but if you need me to do that I can. I also can list all my Addons if necessary.

    Thanks again.
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Quote from Elsia »

    @eve: That bug happens if a previous error occured, can you post all bugs in your bugsack so we can see why "RegisterInfoType" couldn't get loaded?


    I went through my bugsack and found 56 total errors saved from past days. I looked through them all and nothing except the one I posted was from Recount. However, I did notice that errors from a different Addon references AceEvent, like the error I received from Recount. So I am not sure if it relates.

    Posted below:


    [2008/01/28 00:09:13-569-x2]: GroupCalendar\MCDataChannelLib.lua:753: bad argument #1 to 'len' (string expected, got nil)
    GroupCalendar\MCDataChannelLib.lua:753: in function <Interface\AddOns\GroupCalendar\MCDataChannelLib.lua:752>
    <in C code>: in function `SendAddonMessage'
    ColaMachine-1.1\Core.lua:405: in function <Interface\AddOns\ColaMachine\Core.lua:358>
    <in C code>: ?
    AceEvent-2.0-56171 (Ace2):364: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:342>


    [2008/01/20 20:27:53-508-x1]: Proximo-1.4\Proximo.lua:106: attempt to call method 'SetDefaultCommPriority' (a nil value)
    AceAddon-2.0-57245 (Ace2):484: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:461>
    <in C code>: ?
    AceEvent-2.0-56171 (Ace2):300: in function `TriggerEvent'
    AceEvent-2.0-56171 (Ace2):914: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:907>


    There are other errors that look the same as those ones above. I'm starting to wonder if another Addon I have is causing this issue with Recount as well as other Addons and I am only now noticing.
    Posted in: General AddOns
  • 0

    posted a message on Recount
    On the latest version of Recount from the Downloads page here on WoWAce I keep getting an error right when I login. Recount doesn't record any data at all. If I revert back to r58664 it works fine. Both r59628 and r59671 have the error.

    Bug Sack caught the following:

    [2008/01/29 17:28:23-583-x1]: Recount-$Revision: 59671 $\Recount.lua:1368: attempt to call method 'RegisterInfoType' (a nil value)
    AceAddon-2.0-57245 (Ace2):926: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:919>
    <in C code>: ?
    AceEvent-2.0-56171 (Ace2):263: in function `TriggerEvent'
    AceEvent-2.0-56171 (Ace2):914: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:907>


    Thanks for the work on the addon :)
    Posted in: General AddOns
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from Coldfury »






    Hey Coldfury quick question on your layout. What are you using for the text display of battleground objectives?

    Thanks!
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from Velveeta »

    My Shaman WIP:




    Hey Velveeta,

    What addon are you using for your combat log? I'm still using Hitsmode, but it hasn't been updated in awhile, and I've been looking for a replacement.

    Nice setup. I should just ask what addons you are using period, I'm always looking for new ideas.

    Thanks ~
    Posted in: General Chat
  • To post a comment, please or register a new account.