• 0

    posted a message on oSkin
    just to check, i deleted the !!!libraries folder, Ace2, and oSkin, then did fresh installs of Ace2 and oSkin (deleted saved vars as well)
    this is the bugsack error msg
    [2006/09/22 13:27:48-597]: oSkin\core.lua:142: attempt to index local `ddName' (a nil value)
    oSkin\core.lua:142: in function `hookDDScript'
    oSkin\AOElements.lua:548: in function `skinMCP'
    oSkin\AddonFrames.lua:54: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:244: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:917: in function `event'
    AceEvent-2.0\AceEvent-2.0.lua:422: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:402>
    
     ---


    in addition to that, the metamap skin is just blank, all that shows is the map itself and any buttons, no borders, backgrounds, or skins
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    for me the error persists into rev 11671 as well
    Posted in: General AddOns
  • 0

    posted a message on DeuceLog
    already installed ;)
    i intend to give it a nice workout today and then some :-D
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    yeah, its looking like perhaps some of the commits lost yesterday werent redone? ie the metamap fix
    and im still getting this error, ive del'd my savedvars, logged in and out, reloaded ui, still pops the error msg on zone in or reload
    full bugsack error code
    [2006/09/22 11:09:07-593]: oSkin\core.lua:142: attempt to index local `ddName' (a nil value)
    oSkin\core.lua:142: in function `hookDDScript'
    oSkin\AOElements.lua:512: in function `skinMCP'
    oSkin\AddonFrames.lua:54: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:244: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:917: in function `event'
    AceEvent-2.0\AceEvent-2.0.lua:422: in function <...dOns\!!!Libraries\Libs\AceEvent-2.0\AceEvent-2.0.lua:402>
    
     ---


    also the questlog isnt being skinned, but again, im thinking that might be related to the error message, from what ive been able to check so far, everything but the questlog, oCD, GotWood, and MCP arent skinned, tho my toon is in the middle of the wilderness so kinda hard to test them all lol
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    still getting that same error with the new version, im not sure if its because of the error (some of my other frames arent skinned, some are) but oCD and GotWood both arent skinned for me
    also it seems the metamap skin is borked out for me (ie its fullscreen), but im guessing its perhaps related to the error?
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    getting this error in bugsack with the latest revision
    [2006/09/22 09:53:16-588]: oSkin\core.lua:142: attempt to index local `ddName' (a nil value)
    oSkin\core.lua:142: in function `hookDDScript'
    oSkin\AOElements.lua:514: in function `skinMCP'
    oSkin\AddonFrames.lua:54: in function `obj_method'
     ---


    also the functions for oCD and GotWood are missing from AOElements.lua but the calls are still in AddonFrames.lua ;)
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    oSkin for oCD and GotWood?

    in AddonFrames.lua
    if IsAddOnLoaded("oCD") then self:Skin_oCD() end
    if IsAddOnLoaded("GotWood") then self:Skin_GotWood() end


    in AOElements.lua
    function oSkin:Skin_oCD()
    	self:applySkin(_G["oCDFrame"])
    end
    
    function oSkin:Skin_GotWood()
    	self:applySkin(_G["GotWoodFrame"])
    end


    such simple code but such pretty timerbars :)
    Posted in: General AddOns
  • 0

    posted a message on XAD
    looks intriguing so far, got 1 bug type report though, i use a bagmod (bagnon to be precise) and Xad attached itself to the absolute lower left of my screen.
    so i figured, no problem, ill just move it to where i want
    cept, it wont move lol (and yes, i did /xad lock to unlock it 1st ;) )
    so right now ive got it nestled above my chatwindow and behind my bottom fubar panel lol
    not very helpful for clicksies heh
    regardless, looks awesome and i cant wait to see whats to come in future versions :)

    edit:
    got the moving thing working, apparently clickin on an "empty" button did it but not clicking on a button with items listed =S
    although now i can move it around, i cant actually "use" any of the items, all my clicks jus make it look like i pressed the button but nothing happens =\
    Posted in: General AddOns
  • 0

    posted a message on Ace'd KTM?
    i believe they're talkin about KLH Threat Meter
    http://www.curse-gaming.com/en/wow/addons-3488-1-klhthreatmeter.html
    (personally, i dont think anyone should need an aggro management tool, jus play smart ;-P )
    Posted in: Addon Ideas
  • 0

    posted a message on let's call it DropWood ;)
    thanks :)
    like i said, it might be a while, im pretty new to this whole coding thing lol
    writing an entire addon is a lot more than just hacking Id's chat code hehe
    i hope to have some of the basic framework in place over the next few days or so
    its a toss-up, have fun leveling my shaman or work on my shaman mod... ;-)
    Posted in: Addon Ideas
  • 0

    posted a message on let's call it DropWood ;)
    im begging work on a project like this but im also quite new to ace and addon coding so expect it to be a while before we have a alpha to test ;)
    once i get the basics going then we can start with the "add this, add that" requests :)
    (oh and if Tekkub and Moonsorrow don't mind, thats the name, "Sportin' Wood")
    Posted in: Addon Ideas
  • 0

    posted a message on oSkin
    Quote from deezel »

    I have no problems adding files to the .toc, however if you do, you need to restart wow before the changes will happen.


    thats odd, whenever i added my custom.lua into the .toc my custom addons would be skinned but nothing from oSkin, without my custom addons in the .toc, oSkin works fine.
    is there some sort of "proper" naming scheme for files or stucture of the toc file?
    i was just adding my file or commenting and then adding my file
    like
    ## My Custom Addons
    MyCustomAddons.lua
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    interestingly enough, it seems my issue from the other day with the new file format comes from adding a new file to the .toc (for my custom skins) when i add a new .lua to the .toc, oSkin doesnt skin anything, but with my code inserted into the actual oSkin code, works no problem.
    just wanted to post it incase anyone else was banging their head on the wall wondering wtf was going on lol ;)
    Posted in: General AddOns
  • 0

    posted a message on oSkin
    yeap, went through the whole delete saved vars etc before posting and again just now to be sure, same issue persists
    most things enabled by default but not actually skinned in-game
    has anyone else seen behavior like this?
    Posted in: General AddOns
  • 0

    posted a message on DEVELOPERS DEVELOPERS DEVELOPERS!!
    Quote from tekkub »

    capslock bugs me


    somehow, tekkub always makes me laugh lol (literally)
    Posted in: General Chat
  • To post a comment, please or register a new account.