• 0

    posted a message on Basic Question - Tooltip anchoring
    Hi,

    I'll start by apologizing for asking such a basic question, un-related to the Ace development platform. I am an amateur coder, but I wish to learn more and I've hung up on what may be a simple issue.

    I'm trying to grasp the simple dynamics of tooltips, and I've researched wowikki, attempted to deconstruct code from other mods and libraries, and I believe I am just failing to capture some fundemental concept.

    Basic exercise: Re-anchor the default blizzard tooltip to the upper-right corner of the screen.

    The code I attempt follows:

    GameTooltip:ClearAllPoints(); 
    GameTooltip:SetOwner(UIParent, "ANCHOR_NONE"); 
    GameTooltip:SetPoint("TOPRIGHT",UIParent,"TOPRIGHT",-6,-10);


    This obviously doesn't work, and I'm having a hell of a time finding a decent tutorial that fills in whatever it is that I'm missing.


    Again I apologize for the basic nature of my question. I will continue to research on my own, but the sources I could find specific to programming in WoW are limited, and you guys are the ones I look up to as I try to learn.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Grid Layout Simulator
    Hi guys,

    Does anyone know of a method or have a hack/tool that can be used to test layouts in Grid?

    I hate having to actually form up a raid to tweak my layout.


    P.S. -- What's up with GridStatusReadyCheck? Why must I be a raid leader or assist to see this status?
    Posted in: Grid & Grid2
  • 0

    posted a message on [Grid] GridStatusReadyCheck
    This only seems to work if I'm the raid leader or raid assist.

    Is this intended? The default frames show the ready check results just fine without those permissions.
    Posted in: Grid & Grid2
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    I'm still using the release version of AutoBar, but occasionally I install the beta just to track progress...

    What's happening to AutoBar? At one time I could assign multiple categories to buttons, AND add individual items as well.

    Now it seems that all I have available are pre-set categories that I cannot edit. I cannot seem to add individual items to a button with categories.

    For example: I've always had a button for both bombs and quest items. When I don't have a quest item, the button defaults to my explosives, but when I have a quest item, the button defaults to it. I cannot seem to do this with the beta.

    Finally, keybindings. Why are keybindings now assigned to categories instead of buttons? This doesn't seem to be intuitive. I'm certain I could write a macro to click an individual button, but this seems pretty sloppy.

    Flame me if you will. Call it a 'beta' if you must, but this new version of autobar doesn't measure up to the old one in my estimation.
    Posted in: General AddOns
  • 0

    posted a message on Manufac: Retooled Professions
    Quote from Elandril »

    Quote from Zucharn »

    Any word on a fix for the money summary? I can't get it to work with auctioneer or KC_items, just showing the same error I posted up above.


    Actually, I have figured out now that the problem doesn't lie with Manufac, but with KC_Items, when they are installed using WAU. The subfolder "KC_SellValues" (under the modules folder) doesn't get unpacked into the WoW\Interface\Addons directory, and thus it doesn't get loaded.

    Check using "/kci sellvalues" if you have the sellvalues module correctly loaded. If there's a message about an unavailable command, then KCI is wrongly installed.


    I've tried installing SellValues as standalone and as a module under the new KC_Items. In neither case does the money summary work.

    It may very well be a problem with KCI, but it seems there isn't a reliable fix.

    Is there any word on this?
    Posted in: General AddOns
  • To post a comment, please or register a new account.