• 0

    posted a message on Fastest way of detecting heroic-mode item
    Quote from Arrowmaster
    You should always be using ItemID/Itemlink's with GetItemInfo().


    I've got a mod I wrote for our guild where users can specify an item and it does a lookup. If they give a link I use it, but sometimes they'll type in the name of the item and I want to look it up and return the information as a link instead of text.
    Posted in: AddOn HELP!
  • 0

    posted a message on Fastest way of detecting heroic-mode item
    I played with this for awhile and that's what I came up with. Create a tooltip, check the second line.

    To flip this around - has anyone figured out a way to call GetItemInfo and get the heroic version back instead of normal? Or to be able to specify which you want without using an ItemID/Itemlink?
    Posted in: AddOn HELP!
  • 0

    posted a message on Interface panel scrolling and AceGUIWidget-ScrollFrame
    Ok. So if most mods are doing this then I need to make sure my code always works against the trunk as I can't guarantee if my version of the libraries or their version loads first.

    So to the problem at hand - anyone else notice this behavior with the new version of AceGUI?
    Posted in: AddOn HELP!
  • 0

    posted a message on Interface panel scrolling and AceGUIWidget-ScrollFrame
    I've been getting bug reports lately from users that when they change configuration settings the interface options panel would reset to the top.

    I'm using AceConfig and all the other fun bits.

    I didn't see this problem at first so couldn't test. But recently it started happening to me.

    I tracked it down to a new version of AceGUIWidget-ScrollFrame (from alpha release 847). If I don't use this and instead use the version I was developing against (beta release 815) it works fine.

    So I'm not sure if this is the case where my code has become incompatible in a way I don't realize. Or if there's a bug in the new version.

    It also has me curious - I'm downloading release packages off of Curse that are bundling alpha libraries. Is this how the Curse packager works? Should I make sure I'm testing against the alpha versions when I'm doing my own development?
    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.