• 0

    posted a message on Skinner

    Hi Jncl!

     

    Since the last patch I am still getting errors when ever quest dialogs with npc's are opened.

     

    1318x .../ArkInventory/Externals/Ace3/AceHook/AceHook-3.0-9.lua:180: Attempting to rehook already active hook QuestFrame_SetTitleTextColor.
    [string "=[C]"]: ?
    [string "@ArkInventory/Externals/Ace3/AceHook/AceHook-3.0-9.lua"]:180: in function <.../ArkInventory/Externals/Ace3/AceHook/AceHook-3.0.lua:118>
    [string "@ArkInventory/Externals/Ace3/AceHook/AceHook-3.0-9.lua"]:321: in function `RawHook'
    [string "@Skinner/Core/NPCFrames.lua"]:191: in function <Skinner/Core/NPCFrames.lua:190>
    [string "=(tail call)"]: ?
    [string "=[C]"]: ?
    [string "=[C]"]: in function `Show'
    [string "@FrameXML/UIParent.lua"]:2943: in function `SetUIPanel'
    [string "@FrameXML/UIParent.lua"]:2786: in function `ShowUIPanel'
    [string "@FrameXML/UIParent.lua"]:2651: in function <FrameXML/UIParent.lua:2647>
    [string "=[C]"]: in function `SetAttribute'
    [string "@FrameXML/UIParent.lua"]:3253: in function `ShowUIPanel'
    [string "@FrameXML/QuestFrame.lua"]:99: in function <FrameXML/QuestFrame.lua:22>

    Locals:
    (*temporary) = "Attempting to rehook already active hook QuestFrame_SetTitleTextColor."

     

     

    There seem two addons to be involved. "Skinner" and "ArkInventory".

    I have no scripting/modding skills, so I can not tell, on which side, the issue evolves.

     

    Though, when having "ArkInventory" running without "Skinner", the error does not pop.

     

    Maybe, it is only a problem of the settings in one of both? Is there something, I can do to solve it?

     

    Of course, I reported the error on the "ArkInvetory" issues page too!

     

    Any kind of solution would be very much appreciated, thanks in advance!

     

     

    Update:

    I got a comment from Arkayenro from "ArkInventory".

    acehook is a shared library that i tend to load first due to arkinventory starting with "a" tends to be near the top of the load order

    i presume that skinner has an issue and youll need to report the issue to them.

     

    Maybe that helps?

     

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to ilias222:

     

    Oh, ok, good to know. Though I found posts of others saying they're have similar issues with Bartender.

    I really hate switching to other addons I don't know. Have been using Dominos for like 10 years, maybe longer...

     

    But I'll have a look into it.

     

    Nontheless, Skinner is anyway producing plenty of errors.

    I only mentioned the most annoying ones.

    It definitely needs some fixes here and there and I am desperately hoping for an update in the near future.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Hi there!

     

    First: thank you for keeping Skinner still alive. This addon makes a whole difference for me when gaming.

     

    Now, lately there are 2 really annoying errors coming up.

     

    One can be reproduced when using/sitting in a vehicle (ballista etc.), when ever action bar is replaced by the game (but not with the dragon mount of 'dragonflight').

    Action buttons stop working by pressing keybinds. They can be clicked though with the mouse. Only disabling Skinner helps.

    Here the Lua Error that comes with it:

    10x [ADDON_ACTION_FORBIDDEN] AddOn 'Skinner' hat versucht die geschützte Funktion 'UNKNOWN()' aufzurufen.
    [string "@!BugGrabber/BugGrabber.lua"]:480: in function <!BugGrabber/BugGrabber.lua:480>
    [string "=[C]"]: ?
    [string "=[C]"]: in function `UseAction'
    [string "@FrameXML/SecureTemplates.lua"]:364: in function `handler'
    [string "@FrameXML/SecureTemplates.lua"]:690: in function <FrameXML/SecureTemplates.lua:672>
    [string "@FrameXML/SecureTemplates.lua"]:704: in function <FrameXML/SecureTemplates.lua:697>
    [string "@FrameXML/SecureTemplates.lua"]:746: in function `SecureActionButton_OnClick'
    [string "@FrameXML/ActionButton.lua"]:89: in function `TryUseActionButton'
    [string "@FrameXML/ActionButton.lua"]:124: in function `ActionButtonDown'
    [string "ACTIONBUTTON4"]:2: in function <[string "ACTIONBUTTON4"]:1>

    The other one, and that reeeeeaaally drives me nuts is, that randomly - often when entering a dungeon or simply combat, keybinds/action bars stop working.

    Being a healer and dependent on flawlessly working mouseover macros it can literally be leathel when this happens. An ui reload brings back normal functionality but well, it's definitely not optimal. Here is the Error that comes wiht it (I think it was this one)

    10x [ADDON_ACTION_BLOCKED] AddOn 'Skinner' hat versucht die geschützte Funktion 'Button:SetAttribute()' aufzurufen.
    [string "@!BugGrabber/BugGrabber.lua"]:480: in function <!BugGrabber/BugGrabber.lua:480>
    [string "=[C]"]: in function `SetAttribute'
    [string "@FrameXML/UnitFrame.lua"]:199: in function `UnitFrame_SetUnit'
    [string "@FrameXML/PartyMemberFrame.lua"]:408: in function `UpdateMember'
    [string "@FrameXML/PartyFrame.lua"]:116: in function `UpdatePartyFrames'
    [string "@FrameXML/RaidFrame.lua"]:138: in function `UpdateRaidAndPartyFrames'
    [string "@FrameXML/UIParent.lua"]:1813: in function <FrameXML/UIParent.lua:1409>

    Well, not sure, I tried to play around with Skinner settings, if there is something I could turn on/off to make it work, but with no success.

    I use 'Dominos' as my action button bar replacement.

     

    I do love this addon and there is no alternative out there afaik.

    I would really appreciate if you could look into it or, if possible, tell me what I could try to do on my side to make it work again.

     

    Many thanks in advance, have a great day!

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Hey :)

    Fitst of all: thank you for the great addon!

    Now, I've been getting  quite some lua errors for some time (only on login).
    These look as follows:

    Message: AceLocale-3.0: Skinner: Missing entry for 'Help Tips'
    Time: Fri Oct 4 16:29:39 2019
    Count: 1
    Stack: AceLocale-3.0: Skinner: Missing entry for 'Help Tips'
    Interface\AddOns\Skinner\Options.lua:1531: in function <Interface\AddOns\Skinner\Options.lua:204>
    (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:116: in function <Interface\AddOns\Skinner\UtilFuncs.lua:107>
    (tail call): ?
    Interface\AddOns\Skinner\Skinner.lua:132: in function <Interface\AddOns\Skinner\Skinner.lua:84>
    [C]: ?
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:70: in function <...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:65>
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:498: in function `InitializeAddon'
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:613: in function <...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:605>

    Locals: <none>

     

    Message: AceLocale-3.0: Skinner: Missing entry for 'Toggle the skin of the Help Tips'
    Time: Fri Oct 4 16:29:39 2019
    Count: 1
    Stack: AceLocale-3.0: Skinner: Missing entry for 'Toggle the skin of the Help Tips'
    Interface\AddOns\Skinner\Options.lua:1532: in function <Interface\AddOns\Skinner\Options.lua:204>
    (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:116: in function <Interface\AddOns\Skinner\UtilFuncs.lua:107>
    (tail call): ?
    Interface\AddOns\Skinner\Skinner.lua:132: in function <Interface\AddOns\Skinner\Skinner.lua:84>
    [C]: ?
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:70: in function <...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:65>
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:498: in function `InitializeAddon'
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:613: in function <...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:605>

    Locals: <none>

     

    Message: Interface\AddOns\Skinner\Skinner.lua:497: attempt to index field 'obj' (a nil value)
    Time: Fri Oct 4 16:29:49 2019
    Count: 1
    Stack: Interface\AddOns\Skinner\Skinner.lua:497: attempt to index field 'obj' (a nil value)
    (tail call): ?
    Interface\AddOns\Skinner\AddonSkins\RaiderIO.lua:36: in function `skinBtn'
    Interface\AddOns\Skinner\AddonSkins\RaiderIO.lua:43: in function <Interface\AddOns\Skinner\AddonSkins\RaiderIO.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:116: in function <Interface\AddOns\Skinner\UtilFuncs.lua:107>
    (tail call): ?
    Interface\AddOns\Skinner\AddonFrames.lua:111: in function `AddonFrames'
    Interface\AddOns\Skinner\Skinner.lua:397: in function <Interface\AddOns\Skinner\Skinner.lua:397>

    Locals: <none>

     And, since the last update, when going to the companions/battlepet tab, I get this one - reappearing until a ui reload:

    Message: Interface\AddOns\Skinner\Modules\UIButtons.lua:157: attempt to index local 'btn' (a nil value)
    Time: Fri Oct 4 16:34:19 2019
    Count: 1
    Stack: Interface\AddOns\Skinner\Modules\UIButtons.lua:157: attempt to index local 'btn' (a nil value)
    Interface\AddOns\Skinner\Modules\UIButtons.lua:157: in function `clrBtnBdr'
    Interface\AddOns\Skinner\PlayerFrames.lua:1024: in function <Interface\AddOns\Skinner\PlayerFrames.lua:1020>
    Interface\AddOns\Skinner\PlayerFrames.lua:1029: in function <Interface\AddOns\Skinner\PlayerFrames.lua:1027>
    (tail call): ?
    [C]: in function `PetJournal_UpdatePetLoadOut'
    ...dOns\Blizzard_Collections\Blizzard_PetCollection.lua:164: in function <...dOns\Blizzard_Collections\Blizzard_PetCollection.lua:141>

    Locals: self = <table> {
    Prat30 = <function> defined @Interface\AddOns\Skinner\AddonSkins\Prat3.lua:5
    add2Table = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:218
    makeIconSquare = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:775
    CustomPrint = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:1206
    blizzLoDFrames = <table> {
    }
    cebRgns1 = <table> {
    }
    checkShown = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:401
    skinScrollBar = <function> defined @Interface\AddOns\Skinner\Skinner.lua:1415
    tabFrames = <table> {
    }
    SecureHook = <function> defined @Interface\AddOns\ArkInventory\Externals\Ace3\AceHook\AceHook-3.0.lua:336
    blizzFrames = <table> {
    }
    fontP = fontP {
    }
    changeTandC = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:273
    BTg = 0.600000
    resizeTabs = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:956
    SetDefaultModulePrototype = <function> defined @Interface\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:409
    isButton = <function> defined @Interface\AddOns\Skinner\Modules\UIButtons.lua:162
    AUCTION_HOUSE_SHOW = <function> defined @Interface\AddOns\Skinner\AddonFrames.lua:186
    addSkinButton = <function> defined @Interface\AddOns\Skinner\Skinner.lua:601
    MogIt = <function> defined @Interface\AddOns\Skinner\AddonSkins\MogIt.lua:5
    IsEnabled = <function> defined @Interface\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:451
    skinCheckButton = <function> defined @Interface\AddOns\Skinner\Modules\UIButtons.lua:927
    ADDON_LOADED = <function> defined @Interface\AddOns\Skinner\AddonFrames.lua:179
    skinToggleTabs = <function> defined @Interface\AddOns\Skinner\Skinner.lua:1736
    callbacks = <table> {
    }
    UnregisterMessage = <function> defined @Interface\AddOns\Aanye_Mail\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
    getInt = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:562
    clrBtnBdr = <function> defined @Interface\AddOns\Skinner\Modules\UIButtons.lua:154
    hooks = <table> {
    }
    skinTooltip = <function> defined @Interface\AddOns\Skinner\Skinner.lua:1753
    checkAndRun = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:283
    isClassic = false
    secureHook = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:1043
    addButtonBorder = <function> defined @Interface\AddOns\Skinner\Modules\UIButtons.lua:869
    VuhDo = <function> defined @Interface\AddOns\Skinner\AddonSkins\VuhDo.lua:5
    fontSBX = fontSBX {
    }
    SetEnabledState = <function> defined @Interface\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:424
    shieldTex = "Interface\CastingBar\UI-CastingBar-Arena-Shield"
    Printf = <function> defined @Interface\AddOns\DataStore\libs\AceConsole-3.0\AceConsole-3.0.lua:69
    changeRecTex = <function> defined @Interface\AddOns\Skinner\UtilFuncs.lua:246
    uCls = "DRUID"
    applyTexture = <function> defined @Interface\AddOns\Skinner\Skinner.lua:906
    Backdrop = <table> {
    }
    libsToSkin = <table> {
    }
    bdTexName = "Blizzard Dialog Background Dark"
    OnEnable = <function> defined @Interface\AddOns\Skinner\Skinner.lua:299
    NewModule = <function> defined @Interface\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:235
    skinExpandButton = <function> defined @Interface\AddOns\Skinner\Modules\UIButtons.lua:28

     I tried to "fix" it by myself, back and forth by altering the settings and finally by deleting the saved variables and setting up the addon from scratch.
    Interesting was, that the errors on login were the same, where as the companion tab error only came up when personalizing my stuff via Skinner.

    I'm somewhat desperate and would appreciate any hints and ideas regarding this issue.

    Many thanks in advance!

    Posted in: General AddOns
  • To post a comment, please or register a new account.